[icus.general] Frequently asked questions and hints about the AT&T UNIX PC

lenny@icus.ICUS.COM (Lenny Tropiano) (09/28/90)

       Answers to some frequently asked questions about the AT&T UNIX PC,
          as well as some frequent problems and useful hints with them

       Last updated: Thu Sep 27 19:10:00 EDT 1990
		     by Lenny Tropiano, ICUS Software Systems,

       This file is not just for the novice UNIX PC user, there are 
       helpful hints for everyone, from the novice to the most 
       experienced users.  Please email me any suggestions, additions
       or corrections that you may have.  


 1. What are the AT&T UNIX PC, PC7300, and 3B1?  Which do I have?
    UNIX PC and 7300 were the AT&T marketing terms for the original machine,
    with 10 or 20MB hard disk.  3B1 is a more recent name, particularly for
    the 40MB and 67MB model.  The 40MB and 67MB 3B1 also has a different top 
    cover, more than 512K on the motherboard (generally 1MB or 2MB standard),
    and a higher-rated power supply.  "Safari" was the development code name.
    "UNIX PC" refers to all machines in the family.
    The model number should be on the name plate on the bottom of the machine.
    When the keyboard is on the housing, the 7300 case is a slanted wedge 
    shape.  On a 3B1, the monitor is mounted on a square horizontal box 
    protruding above the slanted top of the wedge.  This is because the 40MB 
    and 67MB hard disk is a full-height disk, whereas the 10MB and 20MB, in 
    the PC7300, was a half-height disk.
    The 3B1/UNIX PC/PC7300 was developed and built by Convergent Technologies,
    and was called the S/50 by CT.  Convergent Technologies sold the rights
    to AT&T to resell the S/50, which was dubbed as the PC7300, 3B1, or 
    UNIX PC by AT&T.

 2. I mailed the card to AT&T and did not get my Personal Calendar program.
    (Don't bother mailing anything to AT&T now that refers to the UNIX PC,
    the product line has been manufacturer discontinued for quite some 
    time now)
    David Brierley <dave@Galaxia.Newport.RI.US> says, "I got mine!!  Of 
    course, the manual reflects the version that is mailed out on the 
    floppies, not the updated version that is actually loaded onto the 

    Many machines were shipped with the calendar program in /etc/fixes.
    You have to do a few things to install it.
    Append this to your /usr/lib/ua/Office file:
    Default = Open
    Open=EXEC -d /usr/bin/pcal -c
    Help=EXEC -d /usr/bin/uahelp -h /usr/lib/ua/ua.hlp -t Calendar
    Append this to your /usr/lib/ua/Preferences file:
    Default = Open
    Open=EXEC -d /usr/bin/pcal -p
    Help=EXEC -d /usr/bin/uahelp -h /usr/lib/ua/ua.hlp -t Calendar
    If you are using the pcal that is located in /etc/fixes:
    $ su
    # mv /etc/fixes/pcal /usr/bin
    # mv /etc/fixes/pcal.hlp /usr/lib/ua
    # chown bin /usr/bin/pcal /usr/lib/ua/pcal.hlp
    # chgrp bin /usr/bin/pcal /usr/lib/ua/pcal.hlp
    # chmod 755 /usr/bin/pcal 
    # chmod 644 /usr/lib/ua/pcal.hlp

 3. How do I park the hard disk heads before moving the machine?
    The Miniscribe and Hitachi disks used in the 40MB and 67MB machines 
    parks the heads automatically, and loudly, when the power is turned off.
    Also note that many newer drives have auto-parking mechanisms,
    check with your specific manufacturers for more information.
    If your drive doesn't auto-park (many Seagates don't), or you want 
    to make extra sure that they heads are in the parked position -- 
    after the machine is shutdown, insert the Diagnostics floppy disk 
    and boot from it.  Select Park Disk Heads from the Diagnostics menu.

 4. How do I open the case?  How do I get to the motherboard (for the
    suggested preventive cleaning out of the "dust bunnies")?
    The obvious screws on the bottom allow either removal of the top of
    the plastic case or removal of the plastic case from the metal base.
    Different screws release the plastic case or only the top (the part 
    above the keyboard storage area).  Read the following several paragraphs 
    before removing anything other than the first step: unplug everything 
    from the back. (Oh, yeah: "No user serviceable parts inside" -- but 
    that all depends on the user!)
    First find the keyboard retainer posts (they hold the keyboard to the 
    base--one is next to the socket for the keyboard plug).  Note the seam 
    around the top of the retainer posts.  Remove the covers from the posts, 
    and you'll find a screw inside each.  Remove those screws before 
    removing the screws on the bottom of the machine.  
    When removing the top of the plastic case, there are two or three 
    plastic hook-and-tab catches in the front of the machine, to the right 
    of the floppy drive.  The top of the case must be moved outward slightly 
    (usually with a screwdriver or finger pressure) along the joint to the 
    right of the floppy drive in order to release the catches.  This exposes 
    only the floppy drive, the hard disk (underneath the shielding) and 
    power supply.
    The three screws in the front of the motherboard shielding should be
    removed (if you want to expose the motherboard), and then remove the 
    screw holding the 10-pin video cable from the monitor (left side of the 
    motherboard shielding).  The video connector can be removed from the
    left side of the motherboard.  Then remove the ribbon-like cable that
    connects the motherboard to the power supply (on the right side of 
    the motherboard).  After that the metal shielding can be lifted 
    and slid along the tracks and then flipped up or removed.  This exposes 
    the motherboard.  If you need to remove the motherboard shielding
    completely and the monitor assembly, you need to disconnect the floppy
    and hard disk cables from the motherboard (note the direction of the
    connectors, and when replacing them be very sure that the 20-pin
    and 34-pin connectors are seated correctly on the associated pins).
    If you have a PC7300 power supply, and motherboard, you're floppy
    drive power cable might be connected, as well, to the motherboard.
    To remove the whole assembly, in that case, you'll need to remove
    the power connector from the back of the floppy drive as well.
    Be extra careful when placing the top of the UNIX PC/3B1 back on the 
    machine, a common cause for the machine not powering up after the cover 
    is replaced is the 120VAC connectors (brown and blue wires crimped on) 
    have fallen off the power input.  Make sure they are crimped on tightly 
    before closing the case.  Also be careful of the green ground wire, it 
    has a tendency of getting caught in the fan blades (causing the fan not 
    to start spinning when the machine is turned on) or caught in the case 
    itself.   Be sure everything is working (including the fan) when you 
    close the case and before you fasten the 4 screws.

 5. How can I put in a larger hard disk drive?  Will this increase the speed
    of my machine?  What is the largest disk possible in the UNIX PC?
    Upgrading from a 10MB, 20MB, or 40MB to a 67MB drive requires a 3B1 
    power supply and a 3B1 case top (the 40MB and 67MB drive is full-height).
    There are other solutions to this, you can get half-height drive that
    are faster than 80ms seek time (which the old 10MB and 20MB drives were)
    and have more disk space.  As long as the drive is a ST506/MFM interface,
    and is less than or equal to 1024 cylinders and less than or equal to
    8 heads, the drive will work without *any* hardware modifications.
    To upgrade to a disk, >8 heads and >1024 cylinders there are several
    approaches one can take.  Gaining more cylinders is the easiest of 
    upgrades, all you need to do is replace the WD1010 disk controller 
    (which is socketed on the motherboard at location 21H) with the 
    pin-for-pin compatible disk controller, WD2010.  The WD2010 comes in 
    several varieties, and all seem to work for the most part (WD2010A, 
    WD2010B, etc.).  There has been some discussion in unix-pc.* that 
    people haven't been able to get the WD2010 to work in their older 
    revision motherboard UNIX PC or PC7300.  These machines have a 
    daughterboard that handles the disk circuitry, instead of the 
    all-in-one chip that was replaced in the later models.  I haven't 
    been able to verify this, since my all my experience is with newer 
    releases of the motherboards.
    The operating system, from at least release 3.0 of the operating system
    supported an unreleased motherboard revision P5.1. The P5.1 revision 
    level (like the P3...P5 that you see during the boot phase) includes 
    some extra features such as an extra disk head (expanding to 16 
    read/write disk heads) and extra drive select (giving the UNIX PC the 
    capabilities of expanding to two simultaneous hard disks).  With the 
    appropriate hardware modifications (all requiring some expertise in 
    soldering and reading schematics), one could upgrade their motherboard 
    to emulate this undocumented motherboard revision.  These upgrades 
    weren't released to the public by either CT or AT&T during the 
    life-cycle of the product, but was later released and made public by 
    several people in several different forms.
    o   ICUS Software Systems, Gil Kloepfer, Jr <gil@limbic.ssdl.com> and 
        Lenny Tropiano <lenny@icus.ICUS.COM> offers plans to upgrade your 
	machine to P5.1 status, and details on how to wire your motherboard 
	and build your own circuit to allow two hard disks (maximum of 
	16 heads) to be utilized by the UNIX PC.  The information on how to 
	obtain the kit is available on Ohio State University's UNIX PC 
	Archives as ICUS_HD2.Z.  If you cannot obtain that, you should 
	contact either Gil or Lenny for additional information.  The plans 
	cost $30.
    o   John Milton <...!cis.ohio-state.edu!n8emr!uncle!jbm> has a prebuilt
        circuit board that offers up to 4 hard disks and 2 floppy drives, but
        be forewarned that the operating system only supports the two
        hard disks and one floppy drive.  If the operating system patches
        could be made, John's hardware will support it.  He's offering a
        prebuilt, and pretested board that can be wired into the motherboard.
        The motherboard wiring (jumpers) and soldering will have to be done 
        as well before you can use John's board (this is not a plug in and
        go situation -- it requires some time to wire).  The board and
        instructions cost $75.
    o   FIELD P5.1 PAL upgrade.  The P5.1 instructions were posted to 
        unix-pc.general a long time ago, and are now archived on OSU in
        the P5.1.Z file.  This requires a preprogrammed PAL chip to be
        made, which is available for $6.00 from Brian Botton 

    The largest disk in the UNIX PC/3B1 is:

    o   Motherboard revision P3...P5 (WD1010 disk controller)
	8 heads x 1024 cyls x 16 sectors/track x 512 bytes/sector  =  67.1MB

    o   Motherboard revision P3...P5 (WD2010 disk controller)
	8 heads x 1400 cyls x 16 sectors/track x 512 bytes/sector  =  91.7MB

    o   Motherboard revision P5.1 (modified) (WD1010 disk controller) 
	16 heads x 1024 cyls x 16 sectors/track x 512 bytes/sector = 134.2MB
    o   Motherboard revision P5.1 (modified) (WD2010 disk controller)
	16 heads x 1400 cyls x 16 sectors/track x 512 bytes/sector = 183.5MB

    NOTE:  1400 cylinders if the #define HDMAXCYL in /usr/include/sys/gdisk.h,
    although the WD2010 can support up to 2048 cylinders, the operating system
    cannot.  Also with the multiple hard disk upgrades, mentioned above, you
    can have two disks that can be as large as the above sizes, for the P5.1
    modified motherboard revision.

 6. I heard about something called THE STORE! that contains archived 
    UNIX PC software, how can I access it?
    THE STORE! is no longer available for dialup uucp, which was owned and
    operated by AT&T.  All publicly accessible software that was formerly 
    available there has been moved and archived on the OSU archives (see 

 7. The On-Board Modem (OBM) does not work with some other modems.
    The OBM creates the answerback tones which says for some reason
    that it's a MNP reliable modem?!  This confuses some MNP modems and 
    the Telebit Trailblazer (only if set in MNP reliable mode).  These 
    cannot be altered in the OBM, but often a system which cannot call 
    the UNIX PC OBM can be called by the UNIX PC OBM.

 8. What is the operating system?  Its origins?
    The operating system is based on UNIX System V Release 2, with 
    extensions from BSD 4.1, BSD 4.2, System V Release 3 and 
    Convergent Technologies.  The most recent version is 3.51, with 
    a 3.51m FIXDISK (2.0) available.  The FIXDISK can be gotten from 
    AT&T directly, they will send it out to you free of charge.  Just 
    call the Hotline Support line at 1-800-922-0354, and tell them 
    you want the free FIXDISK 2.0 for the UNIX PC.  The FIXDISK is 
    also available on OSU Archives as FIXDISK2.0+IN.
    Changes in 3.51a FIXDISK 1.0: (all changes are also included in
    the later release FIXDISK 2.0 -- see below)
    New problem: Your machine will occasionally crash with a "panic: addr
    fault in kernel" message, but _only_ if you have installed 3.51a _and_
    you use the OBM (On Board Modem).  If you use a modem attached to any
    serial port, you'll never see the problem.  It is recommended that you
    upgrade directly to 3.51m.  The 3.51a release is not a prerequisite
    for 3.51m, only 3.51 is.
    Hardware flow control works, but is broken.  HFC will consistently
    repeat a block of data in an entirely predictable way.
    The terminal emulator (/usr/bin/async_main) has fixes for the 
 	- lockfiles not being removed
 	- vt100 enter key mapping incorrect
 	- slow performance when using 513 or vt100 emulation		
    The UNIX PC 3.51a Custom Kernel (/UNIX3.51a) has fixes for the 
 	- tty driver does not return null character on break
 	- break sent over modem freezes serial port
 	- lp driver truncates lines to 132 characters
    Kmap (/usr/lib/ua/kmap.610) corrects the misspelling of RollDn in 
    the kmap file for the 610 terminal.
    Ksh (/bin/ksh) has fixes for the following:
 	- dumps core on long input lines while in emacs mode
    Modemcap (/usr/lib/uucp/modemcap) has an entry for the AT&T 4024 
    The Phone Manager (/etc/ph) has fixes for the following:
 	- ph stops logging calls in .history
 	- call screen pops up
 	- ph dies after several calls
    The tam library (/usr/lib/libtam.a) has the following:
 	- newly developed applications linked with the new
 	 tam library can draw windows/contents in one pass
 	 instead of two
    The uucp (/usr/lib/uucp/uucico) has fixes for the following:
 	- uucico hangs at call completion
 	- uucico turns modem speaker on
 	- time stamps incorrect in LOGFILE
    Changes in 3.51m FIXDISK 2.0:

    Fixes found within /unix (/UNIX3.51m):
	- changed print to eliminate false data in unix.log
	- SDLC speedup
	- problems with panics due to clist corruption
 	- fix for the System V "losing i-node" problem.
 	- more lines to register dump (from "panic"): 
 	  inadequate data was being supplied for fault analysis
 	- altered invalid page-fault address test
 	- increased NMOUNT to 8 for users with LARGE or multiple disks
 	console driver:
 	- added fix for lock-up during '--More--' processing of diagnostic 
 	  output ("once again")
 	hard disk driver:
 	- fixed error reports & added >8 head/2nd disk data 
 	- added identification of disk controller (either WD1010/WD2010) 
 	- added gdhdprecomp[] to support variable PreComp and 2 disks
 	- added step rate code to permit other than 0 
 	floppy disk driver:
 	- added fix from Peter Fales
 	tty device driver:
 	- Fixed IXANY in test [as posted to USENET by Peter Fales]
 	keyboard driver:
 	[LBT's note:  if you are currently using the kbd.o device driver
 	 from either Mike Ditto or from THE STORE! it should be removed
 	 and unloaded to access the following "features" of the new 
 	 kbd driver in the kernel]
        [David Brierley said, "I continued to use the Ditto kdb driver 
	 after installed 3.51m and the machine started to act a little
         weird, mostly in relation to the caps-lock and num-lock keys.  
	 Sometimes pressing caps-lock or num-lock would have no effect 
	 and frequently they would light up the corresponding LEDs when 
	 pressed the first time but neglect to turn them off when pressed 
	 the second time.  Unless there is something weird about my 
	 machine I would say that the Ditto kbd driver is incompatible
         with 3.51m.  I don't know about the version from the STORE."]

 	- changed debugger trap from "compiled-in" Control-B
  	  to match DBtrapshort kernel location -- defaults to Control-B.
 	- added save unblanking character (symbol savUBkey) -- defaults to 0.
  	  if user resets to 1, screen restore char will *NOT* be discarded
 	  from input stream.
 	- added triple-key special functions [see below]:
 	  triple key sequence = left ctrl + left shift + caps lock + Fn
  		F1: Identifies keys (and those which are "ON") [help line]
 		F2: Toggles Caps Lock and Right Control keys reversal
 		F3: Toggles Meta-key mode (Left Control becomes Meta)
 		F4: Toggles Save-Unblanking-Char mode
 		F5: Toggles Ramped AutoRepeat speed
 		F6: Toggles "MeterMaid" display
 		    [LBT's note: "What is metermaid you may be asking?  
 		     Metermaid info is in a "hints" file on OSU]
 		(if db.o is a currently loaded device)
 		F7: Toggle use of Kernel Debugger Escape Key
  		    (traditionally a Control-B)
 		F8: Trap into Kernel Debugger(w/o using Escape Key)
 	- changed several keys' Control-* value to provide
 	  better access to 0x00, 0x1e, 0x1f binary values.
 					 Previous       Now
 		- CONTROL-DELETE:	<Illegal>    -> 0x1f
 		- CONTROL-'.':		<Illegal>    -> 0x1e
 		- CONTROL-'/':		<Illegal>    -> 0x1f
 	lp driver:
 	- state-logic code was rewritten entirely to try to make code more 
 	  predictable.  (this will slightly alter sequence of 
	  Error/Paper-Out [!!] messages)
 	mem driver:
 	- fixed error in MPTE-loading [Peter Fales]
 	- fixed error in upper-address limit test [Peter Fales]
 	tty line discipline:
 	- fixed error in IUCLC handling
 	- added code to prevent lockup during _VERY LONG_ lines submitted 
 	  under canonical processing
 	- fixed CLIST-loss problem in 'canon()'
 	- altered delay() call to reflect SVR3.2
    Loadable Window driver (wind.o):
 	- changed 'char' in kspecial to 'unsigned char' to avoid problems 
 	  with Meta-type characters (ie. ones with high-bit set)
 	- mouse's presence is tested after the screen is unblanked (from 
 	  previously blanked condition) and will not display mouse pointer 
 	  if not connected
    Loadable Combo driver (cmb.o):
 	- cleaned up driver code.
 	- corrects erroneous information from earlier versions.

    Asynchronous Terminal Emulator fix (/usr/bin/async_main):

	- lock files not being removed
	- vt100 enter key mapping incorrect
	- Slow performance when using 513 or vt100 emulation		
	- Character echo problems with System75 PBX's
	- Remote terminal usage with the Call Screen


	- If the system battery is dead (the time reverts to
	  January 1, 1970), the replacement 'date' command will
	  reuse the time stored in the filesystem superblock.

    kmap fix (/usr/lib/ua/kmap.610):

	- Misspelling of "RollDn" in the kmap file for the 610 terminal.

    ksh fix (/bin/ksh):

	- dumping core on long input lines while in emacs mode

    modemcap fix (/usr/lib/uucp/modemcap):

	- an entry for the AT&T 4024 modem.

    Phone Manager fix (/etc/ph):

	- call screen pops up
	- /etc/ph dies after several calls
	- /etc/ph stops logging calls in .history

    Remove script:

	- Inserts a confirmation window which allows the
	  user a chance to cancel the removal (in case the
	  wrong item was selected).


	- problems with the data under certain screen blanking 


	- prevent corruption or removal of /etc/inittab

    tam library fix (/usr/lib/libtam.a):

	- Newly developed applications linked with the new
	  tam library can draw windows/contents in one pass
	  instead of two

    Floppy Tape fix (Tbackup.sh):

	- can't remove tape to insert tape 2
	- verify pass checks tape contents (not just whether 
	  it is readable)

    utmp fix:

	- shutdown problems, multiple bogus entries in /etc/utmp.
	- corruption of /etc/utmp file.

    uucp fix (/usr/lib/uucp/uucico):

	- uucico hangs at call completion
	- uucico turns modem speaker on
	- time stamps incorrect in LOGFILE

 9. What third-party hardware is available?
    Presently there are no known distributors that have a selection of
    UNIX PC hardware.  The best source for hardware is the network,
    reading unix-pc.general and misc.forsale.  There is always someone
    selling UNIX PCs and the appropriate hardware expansion.

10. a) I'm trying to set up a printer on my UNIX PC using the lpadmin(1M)
       and accept(1M) command, but they aren't working -- no messages at 

    b) All the jobs on the printer are always followed by a formfeed (FF).

    c) I cannot send bitmapped images to the printer correctly.

    The lpadmin(1M), accept(1M), and reject(1M) commands require the user
    to be logged in (or su'd to) user "lp".  Being su'd as root will not

    # su lp
    $ /usr/lib/lpadmin -plp1 -mdumb -v/dev/lp

    The line printer driver will follow each close() to /dev/lp with a
    formfeed.  There is no way to disable this.  The only way is to set
    up the printer as the raw device.

    $ /usr/lib/lpadmin -plp1 -mdumb -v/dev/rawlp

    8-bit bitmapped images need to go to the raw device, as well.

11. Can I put a 68881 math coprocessor in my machine?  I saw AT&T had
    one for the UNIX PC?

    AT&T (or Convergent Technologies for that matter) never fully developed
    the 68881 floating point math accelerator processor.  The board was
    rumored to sell for ~$2,000 and not increase the performance to the

12. Where can I get GCC and G++ for the UNIX PC?  Has someone already ported
    it?  (Also see item #40)

    Yes, GCC (GNU C Compiler) has been ported to the UNIX PC for quite some
    time.  It's up to release 1.37.1 currently, and has few bugs.  The
    unfortunate thing is that the compiler is very large in size, so programs
    do take quite a bit longer to compile.  

    There is also a G++ (GNU C++ Compiler) as well.  Both are available as
    installation archives from the OSU Archive site (see below).

    The national GNU archive is located on the Internet at prep.ai.mit.edu.
    They allow anonymous FTP transfer.  This is where you will find the
    FSF (Free Software Foundation) founded by Richard Stallman, software
    archives.  You'll find gnu CC, gnu C++, emacs, gnu chess, gnu groff, etc.

13. Has someone ported X-windows to the UNIX PC? What's MGR?  What can it do
    for me?

    No, X has not been ported, and probably won't ever be ported the UNIX PC.
    X is quite large, and there has been several discussions about porting
    it in unix-pc.*, but it's probably not worth the efforts.

    MGR is an alternative windowing environment, developed by Steve Uhler
    at Bellcore, and ported to the UNIX PC by Brad Bosch and Brian Botton.
    The MGR windowing environment can replace the standard /dev/window 
    environment on the UNIX PC quite nicely (it does prevent some UNIX PC
    specific program from being run in this phase, without the wind.o
    loadable device driver loaded).  MGR's user interface is quite similar
    to a SunWindows environment, and raster operations are quite fast.
    MGR is a user program, no driver (besides the pty driver), so it's
    not taking up precious kernel space.  It does require a hardware 
    modification called the VIDPAL.  The VIDPAL (developed by Brian Botton
    <...!laidbak!bilbo!botton>) is a daughterboard that sits sandwiched 
    between the 68010 CPU and the motherboard.  Brian provides the kits for
    $25.00, that will allow on direct access to video memory (required
    for the MGR windowing environment).  This upgrade is simple to complete,
    and is easily reversible.

    MGR is still beta, and can be gotten by anonymous ftp from:
    max.physics.sunysb.edu [] on the Internet.

14. How can I get a full 360K when I format a MSDOS floppy on the UNIX PC,
    normally I just get 320K?   Are there better utilities to manipulate
    files to and from UNIX and MSDOS floppies?

    $ windy /usr/bin/md_format -9

    A suggestion is to get "windy.cpio.Z" from the OSU Archives to run this
    program since if "windy" is left off the command line your window
    will be in an "insane" state after the floppy is formatted.

    Moving files to and from a MSDOS floppy with the standard UA-interface,
    isn't the easiest or most efficient.  Thanks to Emmet P. Gray 
    <egray@fthood.UUCP> and his MTOOLS program (available on OSU Archives)
    you can copy, take directories, delete, and move files easily between
    the UNIX filesystem and the DOS filesystem.  In the newest release 
    (MTOOLS 2.0), Emmet supplied us with mformat, a tool that will format 
    floppies as well.  It formats 360K, 720K, etc.  MTOOLS 2.0 also supports 
    the C:, D:, etc. drive partition from the DOS-73.

15. My archives are old (archivelib.a) reports that is it's a 5.0 archive,
    and it doesn't link (ld) very well with my other archives.

    The archive format was changed from release 3.0 to 3.5 of the operating
    system.  There is an utility to convert the archives to the new format.

    # convert oldarchive.a newarchive.a

    Or you can run:

    # arconvert
    # file oldarchive.a newarchive.a
    oldarchive.a: 5.0 archive
    newarchive.a: 5.2 archive

    And that will convert all the archives in /usr/lib and /lib that are
    old 5.0 archive format to the new 5.2 archive format.

16. How do I get my on-board modem to only be a dial out modem, and not
    answer?  (I share my voice line!)

    The easiest way to do this is to edit (with your favorite editor)
    the /etc/inittab file.  Change the line: 
 		ph0:2:respawn:/etc/getty ph0 1200
 		ph0:2:off:/etc/getty ph0 1200
    NOTE: There is a blank (space) in front of the first "ph0" in the
          lines above.  ph0 may be ph1 if you are using line 2 for the
	  on-board modem.

17. Does my on-board modem support 2400?  I see stuff in the /usr/include
    files that reference 2400 baud internal modem?

    In what Convergent considered future releases of the UNIX PC (P6), there 
    was to be a 2400 baud modem.  This machine was never fully developed to
    production levels, and therefore there is no 2400 baud modem.  The 
    machine was to have a color video, 60MB QIC tape, as well as a 68020 CPU/
    68881 FPU.

18. What do the LED's mean on the left side of my machine (through the grill
    or grating?)

    This is from John Milton's HwNotes series #1.
    0 RED:    This is the "user LED". It can be turned on and off with the
              syslocal(2) call. It is not used by any existing applications.
    1 GREEN:  This is the one most people get wrong. This LED toggles every 
	      time there is a process context change, and is cleared on the 
	      whole second
    2 YELLOW: This is the idle LED. When it is on, there are no processes in 
	      the ready to run state.
    3 RED:    Heart beat LED. This is toggled on the whole second.

    Additional information is available in the HwNote series 1-15 that are
    archived, yes you've guessed it, on OSU.

19. Can I really get 4MB of memory, even with a 1.5MB combo card, 512K RAM 
    card, and 2MB of RAM on the motherboard?

    The answer is yes.  It does require a simple pin-ectomy.  You need to
    fool the hardware to think the 512K RAM card is in a slot that doesn't
    physically exist on the UNIX PC.  For more information on how to do 
    this, grab John Milton's HwNote06 from the archive sites.

20. I'm getting all kinds of HDERRs in my /usr/adm/unix.log file.  What
    should I do?  I also see from time to time lots of FDERRs (or
    possibly TPERRs), what are those?  (regarding FDERRs also see #41)

    There have been several causes for this.  One of course is a bad disk,
    or a disk that has gone bad.  But one should check the other options
    before determining the disk is really bad.

    Dirty power supply contacts have been known to cause these problems.
    Open the machine (see frequently asked question #4) and clean the power
    supply contacts on the ribbon-type cable that goes from the supply to
    the motherboard.

    A weak or faulty power supply too could be your problem.  Test the
    power supply voltages (with the hard drive and motherboard connected
    as a load), using some sort of Y-connector off the power cable to the
    hard drive.  Test the +12VDC and +5VDC supplies with a meter, and
    make sure they are within acceptable tolerances.  If they are too low,
    intermittent HDERRs will occur.  There are several adjustment screws
    on the power supply (marked +5, +12, -12) that can adjust these values.
    Turning clockwise will increase the value, and counterclockwise will
    decrease it.  Faulty power may make a good hard disk or motherboard
    appear to be bad.

    More commonly you'll find FDERRs in your /usr/adm/unix.log file.
    Every time you format a new floppy disk, you'll get at least one.
    Floppy disks are prone to more errors, especially if you get those
    bargain basement brand type.  (I suggest a reliable brand if you
    depend on floppy disks for backups).

    TPERRs might appear if you have a bad or defective cartridge
    tape block.  If you start seeing a lot of these during your backup
    or verify phases, I suggest re-formatting the tape and running
    another surface check (to check for possibly bad streams, or good
    streams that have gone bad).

21. Can I hook up a 3.5" 720K floppy drive to my UNIX PC?  How about
    a 1.2MB or 1.44MB floppy drive?   Can I run both the 3.5" drive and 
    the 5.25" drive on my machine somehow?

    Yes, to the 720K.  No, to the 1.2MB and 1.44MB.

    Putting a 720K 3.5" floppy drive is rather simple, if you are just
    replacing the exist 360K 5.25" drive completely.  In most cases it's
    a one-to-one swap, providing you can get the jumper setting set
    correctly on the 3.5" drive.

    You can run both drives, provided you make a mechanical switch (SPDT)
    to change the drive select between the 5.25" 360K internal drive and 
    the 3.5" 720K (run externally).  You need to make a cable to switch the
    pin 10 (FDRIVE0*) from one drive to the other.  Drilling a hole in the
    case above the left fan grate is a suitable spot.  

    When you use the 720K drive, all you need to do is create an iv
    description file that has 80 cylinders instead of 40, and you get the
    full 800K (80 tracks, 10 sec/trk).  Makes backups go faster!

22. I've heard bad things about the stock 12VDC fans?  Should I add another?
    Replace it with an 120VAC fan?  I hear my fan is going from low to 
    high speed sometimes -- what is this?

    The fans have been a problem with the UNIX PC in a lot of cases.  What
    happens is the 12VDC fan is connected to a thermal switch that will
    alter the speed of the motor when the machine is hot (faster when hot),
    and slower (when cool).  I've seen and personally experienced the fan
    going from fast to slow to off.  The fan collects a lot of dust and
    dirt, and sometimes when switching to the slow speed, it is goes so
    slow that it stops, and doesn't have enough "umph" to start up again.

    Gil Kloepfer theorizes the reason for this happening is that the 12VDC
    fan is constantly running with too little current due to a resistor 
    wired in series with the power supply when the thermal switch is in 
    its normally open position.  When the fan is beginning to malfunction, 
    it will run subtly slower, but enough to keep from moving enough air 
    through the machine.  The thermal switch kicks-up the power, which 
    causes the fan to move faster and cool the machine down until the 
    switch kicks-out again.  This cycling effect keeps going until the 
    fan become excessively weak and clogged with dirt to where it eventually 
    stops working permanently.  But he goes on to add that, in any case, 
    I don't think it's just dirt.

    The next stage is the machine overheats, the power supply cuts out,
    and the machine powers down, then it powers up, and down, and up.
    If you are lucky you catch this before major damage occurs, or you
    take preventive measures beforehand.  Most of the time the power supply
    gets so hot, it dimples the plastic case above it.  This is a sure
    sign that the UNIX PC has had a "meltdown" before.

    What can you do?  Well you can replace the 12VDC fan with a 3" 120VAC
    fan.  The 120VAC fans are more robust, they produce more air current
    (~34CFM normally) and don't draw on the power supply any.  One drawback
    is they are noiser.  The PC7300 cases had two 12VDC fans -- in my
    opinion thats double trouble.

    Some people can go years or forever without ever having a problem, but
    it just takes that one day that you aren't around and the machine
    goes into "meltdown" and then you'll be assured some damage somewhere.

    Radio Shack has an appropriate 120VAC fan for $16.95, cat. no. 273-242.  

23. My machine is booting over and over?  It keeps complaining that 
    Stored Files are being checked, and then it reboots.

    The stock /etc/rc that called when the machine boots up, writes the
    output of the fsck(1M) to the hard disk (/etc/.lastfsck).  This is 
    definitely a problem.  I prefer having control over what fsck does,
    instead of sending fsck with the "-y" option and having it do all
    the work.  A lot of times fsck will delete files or clear them and
    you have no control over what it's doing.

    Check out the fsokay.cpio.Z package on OSU, it contains some enhanced
    /etc/rc scripts and tools to make the booting phase of the UNIX PC
    a lot cleaner and more reliable.

24. The stock uucp with the UNIX PC is the pits, where can I get HDB?
    (HoneyDanBer UUCP).

    HDB binaries are available from the ~/att7300/STORE/HDB3.5+IN.Z on OSU.

25. What is OSU-CIS?  Is everything archived there?  How do I connect to it?

    OSU is a Ohio State University's Computer System and Lenny Tropiano
    <lenny@icus.ICUS.COM> is maintaining the archives.  There is a 
    very large selection of programs that were posted to unix-pc.sources,
    some that were not, and some that are too large to post.  There are
    sources, binaries, hints, patches, suggestions, and a lot of good 
    information for UNIX PC/3B1/PC7300 owners.

    There is a monthly posting regarding access to OSU-CIS's computers
    via dialup uucp, anonymous FTP (Internet) and e-mail server that is
    posted to unix-pc.general and comp.sys.att [by the 1st of every month]

    Connect up to OSU-CIS by one of those means, and grab a current copy
    of the ~/att7300/README.Z file for more information on what is archived

26. Who supports these machines?  Are there any user groups that I can

    You see it!  We (the net) supports them, there are a lot of dedicated 
    people who enjoy these machines and post a wealth of information to 
    the network.  If you aren't connected, get connected!  The unix-pc.* 
    groups, although considered an alternative sub-network, is carried by
    many backbone sites, as well as most UNIX PC sites running news (leaf 
    nodes).  Reading these groups could be your doorway to the answers 
    you desire!   If you aren't running news, but still desire to read
    the group (or even post for that matter), you can receive it by 
    electronic mail, providing you can receive e-mail.  For more 
    information on receiving "unix-pc.*" by e-mail, contact:

	{ames,pyramid,vsi1}!zorch!unix-pc-request (Scott Hazen Mueller)

    If you are in the Silicon Valley area, contact Thad Floryan 
    <thad@cup.portal.com> for information on how to go to the
    "AT&T UNIX User's Group meeting", the fourth Wednesday of every 
    month.  Although it's a generic AT&T UNIX group, 80% of the members 
    own UNIX PC's, as well as Thad, who runs the group.

27. Where can I get my machine serviced?  Fixed?  

    AT&T will still support the machine for another year or so, they have
    to by law.  Their prices are a bit "high" but, they will come on site
    or you can bring your machine to a local depot to replace or repair 
    anything that is wrong with your UNIX pc.  Call 1-800-922-0353 
    (AT&T Hotline support)  -- consulting fees will be required to talk 
    to an engineer, and if it's diagnosed to be a hardware problem the 
    consulting fees will be waived.  Caveat Emptor (let the buyer beware).
    They tend to like to replace lots of parts.  For a $3.00 battery, 
    they'll replace the motherboard (not cheap!)

    A better solution, at least a cheaper one is the ``A Small Computer 
    Repair Company'' (ASCRC).  I know the people who run the operation,
    and they are quite reputable and efficient.  They will diagnose
    you problem, and repair or replace the part that is broken.  They
    will try their hardest to repair the item first.  Their prices
    are much more reasonable than AT&T's, but the catch is you need
    to send the computer (or just the component in question) to them.
    They will repair/replace it and ship it back.  Their turn-around
    time is usually 48-72 hours.  They repair AT&T's 6300, 6300+, 7300,
    3B1 and UNIX PC computers.

    For more information and/or to arrange servicing, contact:

	A Small Computer Repair Company
	5762 Dichondra Place
	Newark, CA  94560

    or call either:

	(415) 430-9226 or (415) 793-6980

28. My clock stopped?  What's wrong?

    Your battery is dead.  On the UNIX PC motherboard there is a 3.0 VDC
    lithium battery.  That battery keeps the RTC (real time clock) 
    operating.  Unfortunately the battery is soldered to the motherboard,
    in most cases.  It's either the round cylinderical canister type,
    or more commonly the flat disc shaped battery.  A suitable replacement 
    can be purchased at Radio Shack, but you'll need to get the disc
    battery holder.  If you desolder the battery from the motherboard,
    solder in the holder, future replacing of this battery will be much
    simpler.   If you are nervous about touching a soldering iron to
    your precious machine, ASCRC will do it for you (see above).

29. I have a X number of floppy disk backup with all of my hard disk 
    on it, and I tried to restore it, on one of the floppies in the 
    middle I got a "Out of phase -- get help" message, what can I do??

    Yes!  Get the public domain program called "afio".  It's available
    in the OSU archives.  It supports reading the floppy disk backup set,
    and will (providing you use the "-k" option) ignore errors and
    recover when it finds the next CPIO ASCII header.  The backup set
    must be written using CPIO and the "-c" option must have been used
    during the writing of the diskettes.

    Syntax for afio to restore is:
    # cd /
    # afio -ivk /dev/rfp021
              ^ k - option to allow dealing with corrupted archives

[Continued in FAQs part 2 -- As of September 21, 1990, this was split into 
 two files since the FAQ became increasingly large]
| Lenny Tropiano           ICUS Software Systems        lenny@icus.ICUS.COM |
| {ames,pacbell,decuac,sbcs,hombre,rayssd}!icus!lenny   attmail!icus!lenny  |
+------ ICUS Software Systems --  PO Box 1;  Islip Terrace, NY  11752 ------+

lenny@icus.ICUS.COM (Lenny Tropiano) (09/28/90)

       Answers to some frequently asked questions about the AT&T UNIX PC,
          as well as some frequent problems and useful hints with them
                        Continuation from Part 1 of FAQ

30. How can I get my machine to ask what load device and what program
    to boot from?

    By default the UNIX PC is set up with the non-verbose system loader.
    This can be changed to the "verbose" loader, and that will ask what
    program and device to load from.
    *** WARNING *** Any time you write to the disk device like the 
    following, be extra careful that you type the correct device name.
    A backup is always recommended.

    Insert a blank diskette in the floppy drive.
    # fdfmt.vl
    # /etc/ldrcpy /dev/rfp020 /dev/rfp000

    Reboot your machine and you'll be able to load from the floppy or
    the hard disk whatever program you desire (not that there is too
    much you can load).  What I have done on my machine is copy the
    several diagnostic utilities to the hard disk (for easy retrieval).

    Insert your diagnostic disk ...
    # mount /dev/fp021 /mnt -r
    # mkdir /dgn
    # cp /mnt/s4diag /dgn/s4diag
    # umount /dev/fp021

    This can be repeated for diagnostics like, STARLAN, Voice Power,
    DOS-73, Floppy Tape, etc.  Name the diagnostic programs something
    unique (slndiag, vpdiag, dosdiag, etc.)  Now you can load from
    the hard disk /dgn/s4diag, /dgn/vpdiag, etc.. and have that diagnostic
    utility handy when needed.
    NOTE: After you do this procedure your system will not reboot 
    automatically (after power failures) without some user input.

31. How do I get multiple login windows? 

    Don't be afraid to edit your /etc/inittab, even though there is a 
    big warning at the top of the file (providing you are careful nothing
    will happen).

    It is fairly easy to start up several windows with logins on them,
    all you need to do is after the:

            vid:2:respawn:/etc/getty window 9600
            vd2:2:respawn:/etc/getty window 9600
            vd3:2:respawn:/etc/getty window 9600
           ^ NOTE: in all cases there is a blank "space" there.

    This will start up 3 windows with logins.  Using the <Shift><Suspd> 
    option of the window manager, you can toggle between all of them.

32. Is there such a thing as Floppy UNIX?  Can I run my machine that
    way and do things like filesystem checks (/etc/fsck)?

    Yes, most definitely.  The Foundation Set diskettes have a floppy
    UNIX on it.  Make a copy of the Floppy Filesystem Disk (Disk 3 of ##)

    Insert the original floppy filesystem diskette, and have a formatted
    10 sectors/track diskette ready.  Type the "fpcp" command and copy it.
    Now that you have a copy, we need to place a copy of /etc/fsck on it.

    # mount /dev/fp021 /mnt
    # cp /etc/fsck /mnt/etc/fsck
    # cp /etc/inittab /mnt/etc/inittab.save
    (That above line is useful for the next situation, see item #32)
    # sync
    # umount /dev/fp021

    Now you have a disk that will help you do a standalone filesystem 

    How do you get to boot this?  First boot the system using the 
    "Floppy Boot Disk" (Disk 2 of ##).  It then will stop and ask you to
    insert the Floppy Filesystem Disk.  Now put your "copy" in.

    When it comes to the first question you then should interrupt this
    script.  This is done by pressing <DEL> (that's <Shift><ESC>).  At
    this point you will get a "#"

    # umount /dev/fp002                     (the disk is already mounted
                                             as /mnt)
    warning: /dev/fp002 not in mount table  (you may get this, it's OK)
    # /etc/fsck -D -S /dev/rfp002           (do your filesystem check)
    # sync;sync;reboot                      (reboot the system)

    NOTE: that /etc/fsck is running off the floppy root filesystem disk
    you have in now, the -s option the restructures (salvages) the 
    free-list on the root filesystem partition.


    For the real UNIX hacker out there (and you are fortunate enough to 
    have a tape drive on your machine) you could grab the fp_unix.sh.Z, 
    conf.sh.Z and kern.cpio.Z files from the OSU Archives.  This is a set 
    of tools, along with the kernel object files for 3.51m, that will let 
    you link in the tape driver (tp.o) to your floppy UNIX kernel and 
    give you full control of the tape device from the floppy UNIX.  This 
    is very handy for doing full backups or restorals from the floppy!

33. My machine hung at the boot message:

               Version #.##x
               Real memory      = #######
               Available memory = #######
               Main board is P3...P5

    (NOTE: Main board could also be P5.1 if your machine was upgraded)

    What can I do?  Do I need to reload everything??

    I've seen this all too many times, so I've taken some precautions.
    9 times out of 10 the /etc/inittab file is either deleted, corrupted,
    or truncated because of some filesystem damage during a system crash.

    The machine will hang there at that Main board prompt forever, since
    /etc/init is looking for the inittab file.  Follow the directions
    in item #32 (above) and insert boot the floppy filesystem disk that
    you made.  On there, if you followed directions, is /etc/inittab.save,
    which can be happily copied to the /mnt/etc/inittab file (when the
    hard disk root filesystem (/dev/fp002) is mounted from the floppy as

    # umount /dev/fp002
    # fsck -s /dev/rfp002
    # mount /dev/fp002 /mnt
    # ls -l /mnt/etc/inittab
    (if it's not there, or corrupted ...)
    # cp /etc/inittab.save /mnt/etc/inittab
    # sync
    # umount /dev/fp002
    # sync;sync;reboot

    The other one time (out of 10) I've seen the /etc/inittab file there,
    but there was /etc/utmp.lck file on the system.  This happens in
    very rare "race" conditions with the pututent(3C) routines.  Removing
    this file, and rebooting will generally recover the system.

34. I heard the UNIX PC isn't the most secure machine?  How can I make
    it a bit more secure?

    The best way to not worry about security is don't allow users on
    your machine that aren't trusted.  Especially users that have shell

    There are several serious problems with the UNIX PC's software,
    specifically the User Agent (UA).  The UA (the windowing environment,
    also known as the Office environment) has some serious security
    problems.  The best solution, of course, would be to remove the
    entire UA system from your machine.  This isn't the easiest 
    procedure (since there are lots of programs scattered all around
    the disk that is tied into the UA) and probably not the most desirable
    for some novice users.  What's so wrong with it?  Well look in your
    trusty manuals, in section 4.  The manual UA(4) states: (talking about
    UA configuration files)

    [...] (page 4)
    EXEC and SH have a number of variations, which are used depending
    on the intelligence of the process being invoked. 
    The variations are specified via option characters as follows:

	-n	Run the process without a window
	-w	Run the process without waiting
	-d	Run the process in a dimensionless window
	-p	Run the process with superuser privileges

    The "-p" option being the problem.  For a little experiment, which
    I do to show the security conscious user (who still likes the UA),
    is give me a non-privileged user account.

    Then I do this, create a file in my home directory called "Office"
    with the following lines:

	Name=Super User UNIX
	Default = Run
	Run=EXEC -pwd $SHELL

    Then I type:

    $ exec /usr/bin/ua

    I select my new object that I just created "Super User UNIX" and then
    at the "#" prompt type "id" for the effect.

    # id
    uid=0(root) gid=0(root)

    OK, convinced?

    If you really *LOVE* the UA, you can do something about this.  Protect
    the programs /usr/lib/ua/uasetx and /usr/lib/ua/uasig so they are
    not executable by "other" and only excutable by a "trusted" group.

    -rwsr-x---   1 root     trusted      4268 Jan  1  1970 /usr/lib/ua/uasetx
    -rwsr-x---   1 root     trusted      2068 Jan  1  1970 /usr/lib/ua/uasig

    Want more?  OK.  Send yourself some electronic mail.  Nothing elaborate
    is necessary.

    $ mail myself < /dev/null
    Select the [mailbox] icon when it comes up, and then when you're in
    /bin/mail, at the "?" prompt type "! /bin/sh", poof!  Root shell.

    # id
    uid=0(root) gid=0(root)
    # pwd

    This can easily be corrected with my "email" program that has been
    posted to unix-pc.sources and is archived on OSU as "email.sh.Z" 
    That program sets the correct user id, group id, and home directory.

    Other things to look for are covered in lots of books on UNIX 
    security.  Directories protected as 777 (world writable), setuid
    programs that aren't very security conscious... etc.

35. What the heck is a +IN suffix on a file?

    On the UNIX PC, "+IN" denotes an "Installable File".  If you were
    to use the UA (and after the above item, you're probably not!) it would
    show that it's an Installable File.  The Installable format is just
    a normal CPIO archive.  The file can be installed by hand by doing:

    # mkdir /tmp/install
    # mv FILE+IN /tmp
    # cd /tmp/install
    # cpio -icduvmB < ../FILE+IN
    # ./Install

    A list of other Suffixes are detailed in the file /usr/lib/ua/Suffixes

36. I heard there was some hidden mode in the diagnostics for expert users
    only?  What is it?  How do I get it?  How do I become an expert?

    The diagnostic floppy has a mode in it for the more experienced system
    testers.  Basically from this mode, there is no need for navigating
    through menus, pick the test and it does it.  The diagnostic tests
    can be run several times (for testing intermittent hardware).  The
    diagnostic output can be sent to a parallel printer for review later,
    and also for unattended testing (since the output can scroll off the
    screen rather easily).

    How do you enter this mode?  Simple.  At the first menu prompt, after
    booting the diagnostic disk, type in "s4test".  If you typed it in
    correctly you will get a prompt.


    From there you can type "?" for a "semi-verbose" command syntax, and
    a list of many of the tests.  For more detail on what tests and subtest
    you can do, grab a nice file by Craig Votava <cmv@ihlpf.att.com>,
    "s4test.info.Z" from the OSU Archives.

37. I turned on my UNIX PC and all I have is a "green screen".  What can
    I do?

    This symptom crops up in a lot of UNIX PC's.  Generally speaking I've
    been able to revive the UNIX PC with only little fuss.  Open the 
    machine, as described in item #4, down to the motherboard.  Carefully,
    reseat all the socketed chips, especially the 68010 CPU.  Vacuum all
    the "dust bunnies" from the machine.  7 times out of 10 the machine
    will boot afterwards.  If the machine still doesn't boot, it could
    be something more serious.  Check with the ``ASCRC'' (see item #27)
    on how you can go about getting the machine repaired.

38. I turn on the machine and I hear the hard disk and fan, but I have no

    Well the first thing you could do is check the "brightness control".
    After you are sure that it's not that, the problem generally goes away
    by replacing the power supply.  If you don't have a spare one, again'
    you'll have to deal with either AT&T or ASCRC.

39. After installing the Development Set, but there are no include header
    files in /usr/include/*?  What gives?

    I've seen this once before, and it has to do with the ordering of
    packages that you install.  Because of a bug in one of the packages'
    Installation script, presumably "Curses/Terminfo Programmers Package,"'
    it tries to copy curses.h to /usr/include, but if /usr/include doesn't
    exist, it will make a *file* called /usr/include, which is really

    To prevent this from happening, install the packages in this order:
                       Curses/Terminfo End User Package
                       Development Set 3.5x
                       Curses/Terminfo Programmers Package

40. Why with GCC (GNU C compiler) available for the UNIX PC, and in
    particular there are pre-compiled binaries for it, why do I need
    the development set (which is hard to come by in the first place)?

    Arnold Robbins <arnold@skeeve.ATL.GA.US> says ...

    For a number of reasons.
    1.  You need the include files from /usr/include and /usr/include/sys.
    2a. You need 'as', the assembler.
    2b. You need 'ld', the loader.
    2c. You need the C libraries (/lib/libc.a, etc).
        None of these come with GCC.
    3.  If you're starting with just GCC source, you need the C compiler
        for bootstrapping.

    Note that bootstrapping GCC from scratch on a Unix-PC is a painful
    operation (requiring much time and disk space).  You're much better 
    off using the binaries that are on osu-cis, and/or bootstrapping with 
    an earlier version of GCC.  The only problem with using the binaries
    off osu-cis, is adhering to /usr/local/bin convention compiled into
    these binaries.

    GAS (GNU assembler) and the GNU loader (ld) aren't ported for use with
    the UNIX PC, at least not completely.

41. I'm receiving a lot of floppy access errors (FDERR) when I format, or
    when I try to access the floppy drive for write.  What's the problem 

    Jon H. LaBadie, Boyd Ostroff, and Perry Miller have suggested to me
    that it could be the light occluding the write protect sensor on the
    floppy drive.  The easiest solution for this is to get a can of 
    compressed air, or blow real hard into the floppy aperature several
    times.  This generally will remove the dust or dirt from the area,
    and hopefully will solve the problem.  (With the light being blocked,
    the floppy drive is considered permanently write protected!)  

    If the problem persists after you follow the *simple* solution, you
    might have to open the machine, remove the floppy drive and do a
    closer examination.  If all else fails, a standard TEAC 360K floppy 
    drive is the one-for-one replacement.

42. I'm running rn(1) from the on-board modem device (/dev/ph[0 or 1])
    and it's coming up with.

    		Can't open /dev/tty.

    The problem is a line in the term.c file.  The lines that have to
    be changed for rn to work are:

    Before change:

    		devtty = open("/dev/tty",O_RDONLY);
    		if (devtty < 0) {
			printf(cantopen,"/dev/tty") FLUSH;

    After change:

    		devtty = open("/dev/tty",O_RDWR);    /* changed for UNIX PC */
    		if (devtty < 0) {
			printf(cantopen,"/dev/tty") FLUSH;

    This is since the /dev/phN devices *require* DATA connections to
    be opened with O_RDWR, so changing the O_RDONLY (or in some 
    versions the number "0") will solve your problems.

43. Can I do more than uucp(1) or cu(1) with my STARLAN boards?  Can I hook 
    the STARLAN to Ethernet? 

    Let me answer the second question first, no, you cannot connect STARLAN
    to an Ethernet network, at least not directly.  STARLAN, or in the case
    of the UNIX PC, STARLAN-1 (1BASE5) is a 1Mbps (megabits/sec) network over 
    twisted pair wire.  The URP protocol used to communicate over STARLAN-1 
    on the UNIX PC.  The newer STARLAN standard is STARLAN-10 (10BASE2) and
    is 10Mbps which is more *like* Ethernet.  The protocol used is the ISO/OSI 
    standard, and therefore it's interconnectability is increased.  However, 
    this is *NOT* compatible with the UNIX PC version.  There is an expensive 
    item that AT&T sells, called the STARLAN 1:10 BRIDGE.  This connects the 
    two networks together, if this is a necessity, but plan to spend around 
    $4,500 for the convenience.  (AT&T PEC Code: STARLAN 1:10 BRIDGE 2611-005)
    According to AT&T STARGROUP documentation, there is software available
    to interconnect STARLAN-10 hardware to Ethernet using IEEE 802.3, TCP/IP
    protocol, this of course in conjunction with the BRIDGE could connect
    STARLAN-1 via the STARLAN 1:10 BRIDGE to STARLAN-10, and then to Ethernet,
    a round-about way, but presumably possible.

    If you want to connect your UNIX PC to a *real* Ethernet, you'll need to
    hunt down the AT&T UNIX PC Ethernet board.  This board runs a version
    of the TCP/IP drivers, distributed by Wollogong.  The board will require
    the proper cables, as well as, a tranceiver.  This increases the cost of
    Ethernet interconnectability.  The Wollogong TCP/IP drivers are an older
    version, which I'm sure isn't support by Wollogong anymore.  It's rumored
    that there are many bugs, and the throughput of the board is no where
    near what Ethernet should be getting.  I was told that throughput over 
    STARLAN-1 was better than over the TCP/IP Ethernet board, where if
    it were working properly shouldn't be the case.

    Thanks to the hard work of Roger Florkowski (cs.utexas.edu!taliesin!roger),
    UNIX PC STARLAN users don't have to be limited with just uucp'ing and
    cu'ing over the network.  He has ported and created a bunch of BSD network
    utilities (r*commands).  With his package, which was posted to 
    unix-pc.sources, and now resides archived on OSU-CIS (bsdslan.cpio.Z),
    you can do remote tape operations, remote copies, and remote shell 

44. Can I run SLIP (Serial Line Internet Protocol) on my UNIX PC?

    So far there hasn't been anyone who ported a SLIP device driver. That 
    would be the optimal solution, but in the interim we do have an
    answer for those who want to run SLIP.  

    There is the KA9Q/W9NK TCP/IP Version 890421.1 available for the
    UNIX PC.  Thanks to Phil Karn (the original developer), Gary Sanders,
    and Rob Stampfli the package supports SLIP (which in theory over
    a modem or direct serial line (preferably 9600 baud or higher) one
    could SLIP on over (sorry for the pun) to an Internet machine allowing
    Dialup/Direct SLIP logins.  With the pseudo-tty driver (pty) you
    can have multiple TELNET sessions (even on the UNIX PC side).  Built
    into the "net" package is FTP, TELNET, FINGER, SMTP, and others.

    KA9Q is available from OSU-CIS, Gary Sander's BBS or via anonymous
    uucp login on Rob's UNIX PC:

	kd8wk Any ACU 2400 16147598597 in:--in: uucp word: anonymous

	To obtain the net source, issue the following uucp command:

	    uucp kd8wk!~/pub/netsrc.cpio.Z /usr/spool/uucppublic

	To obtain an executable for the AT&T 7300, enter the following:

	    uucp kd8wk!~/pub/netexe.7300.Z /usr/spool/uucppublic

    Gary's HAM RADIO BBS Access:

	System Name: 	N8EMR
	Phone:		614-895-2553 (19.2K Trailblazer, 2400, 1200)
	Login:		hbbs 
	Data Settings:	8 Bits, NO Parity, 1 Stop Bit
	Times: 		24hrs

45. I'm having trouble configuring my Hayes compatible external modem on
    the UNIX PC?  How do I do it?  

    Thanks to Jim Adams, I have included in the OSU Archives, HDB_Modem.Z, 
    which is an informational posting (posted to unix-pc.uucp 
    and comp.sys.att) on how to set up your external modem under HDB uucp.  
    The file particularly uses the "hayes" modem as the example, although
    information could probably be extracted for uses with other modems.
    If you want information on how to set up your Telebit Trailblazer modem,
    get the file tb-setup.sh.Z, also archived.

    This posting was too large to include in its entirety here, so a 
    completely seperate posting was made.  He goes into how to set up
    the modem, proper cabling, proper Devices and Dialers entries, and
    a discussion on HFC (hardware flow control).

46. What are the consequences of "fsck -s" (salvaging the freelist)?

    Jim Adams sent me some information I'd like to share with you, regarding
    the uses (and dangers) of salvaging the freelist using the fsck(1M)

    fsck(1M) provides for a method of salvaging and reconstructing the
    freelist maintained by the UNIX filesystem.  It is dangerous to
    haphazardly do anything with the filesystem, as well as just 
    reconstructing the freelist.  If the filesystem isn't in a good
    state, it's possible that the freelist could be further damaged by
    just salvaging it.  fsck(1M) will salvage the freelist when necessary,
    or when the question "SALVAGE (Y/N)?" is answered "yes". 

    Jim has said, that the alternative method, fsck -S, should be used
    if you wish to salvage the freelist.  The salvage will only be done
    if the filesystem is properly constructed, and nothing damaging could
    occur by it's reconstruction.   If errors are found during the fsck
    phases, other than errors like "POSSIBLE FILE SIZE ERROR I=nnn" (which
    occurs from sparse files, also known as files with holes in them)
    the salvage will not be done.

    fsck(1M) is designed to be run on a mounted root filesystem, as 
    long as the block device is used and the system is in a quiescent
    (quiet) state.  fsck(1M) can be run on the raw/character device when 
    the filesystem isn't mounted, and this is generally much faster.  
    fsck(1M) will automatically reboot the system without sync'ing, if 
    the "mounted" root filesystem was modified, just as you should (since 
    the in-core image of the filesystem would be different).  There is no 
    "re-mount" facility on the UNIX PC, otherwise the root filesystem 
    could just be remounted.

    Another suggestion made was to run "fsck -D" to check directories
    for bad blocks.  This takes longer, but is considered worth it.
    (fsck -D is similar to the MSDOS CHKDSK facility)

47. What does the option to "dismount -s" do?

    It should never be used, it's an historical option (as the manual 
    notes), used to un-mount the "Syquest" external drive.  This 
    unfortunately causes the first hard disk to RECAL if you don't have 
    the second disk upgrade.  With the second disk upgrade it improperly 
    un-mounts all the filesystems, but to my knowledge doesn't handle 
    the /etc/mnttab file correctly for all the partitions on the second

    In my opinion, it's much safer to use multiple /etc/umount commands,
    to un-mount multiple partitions.  This works for all cases, and there
    is no second guessing on what the command is actually doing.  If you 
    want to mimic the operation of dismount, you can easily issue the 
    "sync" command before the "umount" command.  As far as clearing the 
    "pulled-flag" as the manual indicates, I never had any problem just 
    using the /etc/umount command (on floppies, as well as, my other 
    partitions and hard disk)

48. What's /etc/update?  What does it do? 

    /etc/update is an antiquated command, that is no longer necessary
    to be used.  It is not a shell script, but could easily be written
    as one.  The executable, /etc/update basically takes one argument,
    the number of seconds to sleep, or defaults to 30 (I believe).  It
    then sleeps that interval and then issues a sync(2) system call.  
    This is a continuous process, it detaches itself from the current
    tty with the setpgrp(2) call, and closes all file descriptors 0, 1,
    and 2 (stdin, stdout, and stderr).  It was to be run by /etc/init,
    as a boot-time process, and was to remain there for the duration of 
    the machine's uptime.


   Thanks to the following people, and I apologize if I inadvertently left 
   your name out.

          Lenny Tropiano     <lenny@icus.ICUS.COM>
          Gil Kloepfer, Jr.  <gil@limbic.ssdl.com>
          Brian Botton       <botton@i88.isc.com>
          Brad Bosch         <brad@i88.isc.com>
          Darren Friedlien   <darren@bacchus.bacchus.com>
          Thad Floryan       <thad@cup.portal.com>
          Mike "Ford" Ditto  <ditto@amix.commodore.com>
          Craig Votava       <cmv@ihlpf.att.com>
          John McMillian     <jcm@pegasus.att.com>
          Jan Isley          <...!gatech!bagend!jan>
          John Milton        <...!cis.ohio-state.edu!n8emr!uncle!jcm>
          Alex S. Crain      <alex@umbc3.umbc.edu>
          Robert Granvin     <rjg@sialis.mn.org>
          Roger Florkowski   <...!cs.utexas.edu!taliesin!roger>
          Brant Cheikes      <brant@manta.pha.pa.us>
          Mark Dapoz         <...!cs.utoronto.edu!hybrid!mdapoz>
          Scott H. Mueller   <unix-pc-request@zorch.SF-Bay.ORG>
          Emmet P. Gray      <...!uunet!uiucuxc!fthood!egray>
          Mark Galassi       <rosalia@max.physics.sunysb.edu>
          David Brierley     <dave@Galaxia.Newport.RI.US> 
          Arnold Robbins     <arnold@skeeve.ATL.GA.US>
	  Jon H. LaBadie     <...!princeton!jonlab!jon>
	  Boyd Ostroff       <ostroff@oswego.oswego.edu>
	  Perry Miller       <pbm@cup.portal.com>
          Karl Kleinpaste    <karl@cis.ohio-state.edu>
          Gary W. Sanders    <...!osu-cis!n8emr!gws>
          Rob Stampfli       <...!osu-cis!n8emr!kd8wk!res>
	  James Warner Adams <adams@ucunix.san.uc.edu>
   All the people who were kind enough to make suggestions, additions,
   and corrections -- the list is a bit too long to include here.

| Lenny Tropiano           ICUS Software Systems        lenny@icus.ICUS.COM |
| {ames,pacbell,decuac,sbcs,hombre,rayssd}!icus!lenny   attmail!icus!lenny  |
+------ ICUS Software Systems --  PO Box 1;  Islip Terrace, NY  11752 ------+
| Lenny Tropiano           ICUS Software Systems        lenny@icus.ICUS.COM |
| {ames,pacbell,decuac,sbcs,hombre,rayssd}!icus!lenny   attmail!icus!lenny  |
+------ ICUS Software Systems --  PO Box 1;  Islip Terrace, NY  11752 ------+